Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Deutsches Simutrans Forum. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

Xelofino

Fortgeschrittener

  • »Xelofino« ist der Autor dieses Themas

Beiträge: 385

Wohnort: Schweiz

Beruf: noch_nicht_Student

  • Private Nachricht senden

1

Mittwoch, 22. Dezember 2010, 19:23

Nightly Builds unter Mac OSX?

Simutrans-Version: Simutrans Nightly Builds r4082
Simutrans Nightly Builds r4082

PAK-Set (+zusätzliche PAK-Dateien):
pak64 + Addons (für Netzwerkspiel)

Betriebssystem:
Mac OSX

Fehler (möglichst genaue Beschreibung):
Zeigt beim auswählen des Servers in der Serverliste sofort : "Server antwortet nicht", an(Bei jedem).

Verhalten (Absturz, Einfrieren, ...):
Gar nichts...Man kann sich einfach nicht verbinden

Ich habe mal auf dem Mac meiner Mutter versucht auf den Servers zu spielen(Da mein Internet ziemlich langsam ist wie viele schon wissen) aber schon beim Auswählen scheitere ich. Ich gehe auf den Server und es steht sofort : "Server antwortet nicht".
Hat jemand eine Ahnung an was das liegen könnte?
Hat jemand einen Mac wo er Nightly Builds spielt?

Firewall ist nicht aktiviert

Xelofino
"Fallen ist keine Schande, aber liegen bleiben."

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Xelofino« (22. Dezember 2010, 19:24)


2

Mittwoch, 22. Dezember 2010, 20:20

Was für ein MAC? Und einmal "simutrans -debug 4 -log 1" starten, das gibt es zusätzlcihe Meldungen. Bitte die simu.log hier posten (Nur die letzten 100 Zeilen.)

Kann man simutrans als Server starten? "simutrans -server 13353"

Xelofino

Fortgeschrittener

  • »Xelofino« ist der Autor dieses Themas

Beiträge: 385

Wohnort: Schweiz

Beruf: noch_nicht_Student

  • Private Nachricht senden

3

Mittwoch, 22. Dezember 2010, 20:41

Einen Intel Mac

Also ich weiss ob das etwas hilft aber hier mal ein paar Zeilen die nur auftreten wenn ich auf den Server klicke. Ich habe noch nicht so viel Erfahrung mit Terminal/Eingabeaufforderung also...
Als Server starten bringt das gleiche.

Message: network_command_t::rdwr: read packet_id=1, client_id=0
Warning: network_check_activity(): received cmd id=1 nwc_gameinfo_t from socket[10]
Message: nwc_gameinfo_t::execute:
Message: network_command_t::rdwr: write packet_id=1, client_id=0
Message: packet_t::send: sent 20 bytes to socket[10]; id=1, size=20, left=-20
Message: packet_t::send: sent 20 bytes to socket[10]; id=1, size=20
Message: socket_list_t::remove_client: remove client socket[10]

Xelofino
"Fallen ist keine Schande, aber liegen bleiben."

Cruzer

Entwickler pak192.comic & Supermoderator

Beiträge: 1 463

Wohnort: Graz, AT

Beruf: Softwareentwickler

  • Private Nachricht senden

4

Mittwoch, 22. Dezember 2010, 21:22

Kann ich bestätigen... selbes Problem bei meinem Intel x86-64 Mac...
Ex-Entwickler und Gründer des pak192.comic, Betreiber von Simutrans Hosting

5

Mittwoch, 22. Dezember 2010, 22:17

Ich meine, den Server starten bring keine Meldung wie "Cannot open socket" oder so?

jonasbb

Entwickler pak192.comic

Beiträge: 1 365

Wohnort: Saarbrücken

Beruf: Student

  • Private Nachricht senden

6

Mittwoch, 22. Dezember 2010, 23:01

Wenn es nicht möglich ist ein Socket zu öffnen, dann sollte es doch auch keine Serverliste geben?
Oder funktioniert das anders?
(Sorry, aber ich kenn´ den Code da gar nicht.)

7

Mittwoch, 22. Dezember 2010, 23:10

Wenn die Serverliste geht, sollte auch das Verbinden klappen. Der einzige Unterschied ist, dass das über Port 13353 anstatt 80 geht. Daher vermute ich, dass das doch ein Firewall-Problem ist.

Cruzer

Entwickler pak192.comic & Supermoderator

Beiträge: 1 463

Wohnort: Graz, AT

Beruf: Softwareentwickler

  • Private Nachricht senden

8

Sonntag, 2. Januar 2011, 20:26

Firewall deaktiviert...

Serverliste laden, geht immer...
Verbinden funktioniert nie, werder lokal, noch über das Netzwerk.
Nichteinmal am gleichen Rechner, wenn Port 80 verwendet wird. Und dennoch wird NIE eine Fehlermeldung im Simutrans Log ausgegeben, weder Client, noch Server.
Auch funktioniert ein "manueller" Verbindungsversuch mithilfe des "-load net:127.0.0.1" oder des Laden Dialogs nicht...
Ex-Entwickler und Gründer des pak192.comic, Betreiber von Simutrans Hosting

9

Montag, 10. Januar 2011, 10:25

Bitte mal heutige MAC-Version mit NEtzwerk ausprobieren.

Cruzer

Entwickler pak192.comic & Supermoderator

Beiträge: 1 463

Wohnort: Graz, AT

Beruf: Softwareentwickler

  • Private Nachricht senden

10

Montag, 10. Januar 2011, 21:12

Funktioniert!
(Und großes danke, dass ihr nicht auf die Macintosh Platform vergessen habt.)
Ex-Entwickler und Gründer des pak192.comic, Betreiber von Simutrans Hosting

11

Montag, 10. Januar 2011, 22:22

Was, ganz und gar keine Einschränkungen? Ich habe nämlich den Timeout komplett weggelassen ...

Cruzer

Entwickler pak192.comic & Supermoderator

Beiträge: 1 463

Wohnort: Graz, AT

Beruf: Softwareentwickler

  • Private Nachricht senden

12

Dienstag, 11. Januar 2011, 06:25

Ich hätte angenommen, es ist normal für den Netzwerkmodus, das sich die Anwendung ab und an (ok, doch ziemlich oft...) komplett aufhängt. ("Anwendung reagiert nicht mehr!")

Aber zumindest kommt man schon so weit, dass man sich ohne Probleme verbinden kann.

Nachtrag: Getestet auf localhost, welcher zugegeben sehr optimale Bedingungen bietet...
Ex-Entwickler und Gründer des pak192.comic, Betreiber von Simutrans Hosting

13

Donnerstag, 13. Januar 2011, 00:04

Ok, bitte r4170 testen, es sollte jetzt alles funktionieren (bis auf den Pakvergleich unter PowerPC).

Falls er wegen flascher Revision nicht verbinden will, einfach mal für pak64 unter Datei laden "net:gift.physik.tu-berlin.de" tippen, damit wird der Versionsvergleich umgangen und trotzdem verbunden. (Meist fliegt man kurz danach wieder raus, weil irgendwas dann doch anders ist, aber für Tests sollte das reichen.)

Cruzer

Entwickler pak192.comic & Supermoderator

Beiträge: 1 463

Wohnort: Graz, AT

Beruf: Softwareentwickler

  • Private Nachricht senden

14

Donnerstag, 13. Januar 2011, 19:14

Ich konnte mich einloggen und mich auf dem Server gift.physik.tu-berlin.de umsehen.
Scheint zu funktionieren! Sehr vielen dank! :)
Ex-Entwickler und Gründer des pak192.comic, Betreiber von Simutrans Hosting