Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Factory spacing
#1
Hallo,

ich wollte mir gerade eine neue pak128 Karte mit der aktuellen stable erstellen, nur leider scheint factory spacing irgendeinen Murks zu machen. Sowohl bei 40% innerhalb 100 Felder als auch 100% innerhalb 100 Felder versucht es die Fabriken eines Industriezweiges möglichst weit auf der Karte zu verteilen. Dazu sind aktuell etwa 90% der Fabriken am linken Kartenrand. Min spacing ist auf 1
Zitieren
#2
Ist evt. links die einzig geeignete Klimazone?

Ansonsten sind deine Angabe etwas zu knapp: Was hast du genau eingestellt, bzw. was hast du erwartet?
Zitieren
#3
Die neue Karte war grob 3000x3000, daher sollten Klimazonenprobleme nicht auftauchen. Ich habe auf meinen Karten mit pak128 min_spacing stets auf 1 gestellt, damit die Industriegebiete überhaupt Platz finden. Mit dem neuen Parameter wollte ich eigentlich nichts anfangen, habe aber max_spacing percentage auf 40 gestellt und max_spacing auf 100, wobei ich dachte, dass das bedeutet das 40% (mindestens oder auch nicht) der Zulieferer einer Fabrik höchstens 100 Felder entfernt entstehen.
Zitieren
#4
dom700,'index.php?page=Thread&postID=100105#post100105 schrieb:max_spacing percentage auf 40
interpretiere ich als maximalen Abstand von 40% der Kartengröße.
Zitieren
#5
Wenn beides spezifiziert ist, wird nur eines genommne. Im übrigen gilt dies nur für Verbraucher, die neu dazukommen. Verbindungen zu bereits existierenden Verbrauchern gehen auch über die ganze Karte.
Zitieren
#6
Ich habe jetzt mal einen Screenshot einer neu erstellten Karte gemacht.
[Bild: simutrans_bug.jpg]

Diesmal wurden tatsächlich einfach die vorgegebenen Einstellungen verwendet
Zitieren
#7
Ist vielleicht Zufall. Bis zu einer Kartengröße von 3000x1000 (mehr kann mein Rechner nicht in utner 10 Minuten) gibt es zwar manchmal Häufungen Oben und Links, aber ebenso oft auch durchaus durchmischte Karten.
Zitieren
#8
Zufall....hmmm
Ich habe jetzt 4x eine neue Karte erstellt und das Ergebnis war quasi identisch, sprich unbrauchbar.
Ich habe es jetzt quasi manuell probiert, also eine Karte ohne Industrieketten erstellt. Die ersten Ketten, die ich mit dem Tool der öffentlichen Hand erstellen ließ wurden normal auf der Karte verteilt ("normal", einfach wild verteilt, ohne dass man sie in den nächsten 20 Spieljahren verbinden könnte)
Die späteren Ketten landeten am linken Kartenrand
Zitieren
#9
Es wird aber in allen Faellen die gleiche Funktion aufgerufen ?(
Zitieren
#10
Naja die Information die ich weitergeben wollte, war auch ehr, dass die ersten gesetzten Industrieketten in Ordnung sind und erst nach ein paar Ketten auf einmal alles am linken Kartenrand landet. Zwischen Industrieketten bei der Kartenerstellung setzen und Industrieketten danach setzen ist wirklich kein Unterschied erkennbar gewesen
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste