Deutsches Simutransforum

Normale Version: Probleme mit der Wasseranimation
Du siehst gerade eine vereinfachte Darstellung unserer Inhalte. Normale Ansicht mit richtiger Formatierung.

Dwachs

siehe

http://forum.simutrans.com/index.php?topic=12941.0

Es liegt vermutlich daran, dass die animierten Wasserfelder nicht genau die gleiche Form wie die flache Kachel aus der Grund-Textur dat.

Hat jemand noch die Quellen davon ? Sojo? Alex?
Dwachs,'index.php?page=Thread&postID=100248#post100248 schrieb:Es liegt vermutlich daran, dass die animierten Wasserfelder nicht genau die gleiche Form wie die flache Kachel aus der Grund-Textur dat.
Was meinst du damit genau, also welche Datei muss ich wie anpassen?

Dwachs

Die Grafiken aus
Code:
Obj=ground
Name=Water
Image[0][egal]=...
muessen die gleiche Form haben wie diese Grafik:
Code:
Obj=ground
Name=LightTexture
Image[0][0]=
Dh die Grafiken Water[0][egal] muessen transparent (intransparent) sein, wo LightTexture[0] transparent (intransparent) ist. Bei Animationsschritt 0 passt noch alles, danach nicht mehr.
Liegt der Fehler darin, dass noch immer die alten Dateien verwendet werden?

Im pak96.comic wurde seit einiger Zeit nichts verändert. Bisher lief es fehlerfrei. Erst mit den neuen Böden ist der Fehler aufgetreten!?

Code:
Obj=ground
Name=LightTexture
Image[0][0]=texture-lightmap.0.14
Image[1][0]=texture-lightmap.0.6
Image[2][0]=texture-lightmap.0.7
Image[3][0]=texture-lightmap.0.2
Image[4][0]=texture-lightmap.0.4
Image[5][0]=texture-lightmap.0.11
Image[6][0]=texture-lightmap.0.3
Image[7][0]=texture-lightmap.0.12
Image[8][0]=texture-lightmap.0.5
Image[9][0]=texture-lightmap.0.1
Image[10][0]=texture-lightmap.0.13
Image[11][0]=texture-lightmap.0.10
Image[12][0]=texture-lightmap.0.0
Image[13][0]=texture-lightmap.0.8
Image[14][0]=texture-lightmap.0.9


Code:
# the deeper the bluer
#+ animation
Obj=ground
Name=Water
Image[0][0]=water.0.0
Image[0][1]=water.0.1
Image[0][2]=water.0.2
Image[0][3]=water.0.3
Image[0][4]=water.0.4
Image[1][0]=water.1.0
Image[1][1]=water.1.1
Image[1][2]=water.1.2
Image[1][3]=water.1.3
Image[1][4]=water.1.4
Image[2][0]=water.2.0
Image[2][1]=water.2.1
Image[2][2]=water.2.2
Image[2][3]=water.2.3
Image[2][4]=water.2.4
Image[3][0]=water.3.0
Image[3][1]=water.3.1
Image[3][2]=water.3.2
Image[3][3]=water.3.3
Image[3][4]=water.3.4
Image[4][0]=water.4.0
Image[4][1]=water.4.1
Image[4][2]=water.4.2
Image[4][3]=water.4.3
Image[4][4]=water.4.4

Dwachs

Der Fehler liegt darin, die Aenderung in r6964 (unbeabsichtigt) voraussetzt, dass die Wasser-Grafiken [0][egal] alle dieselbe Grundform wie die Standardbodenkachel haben.

Wie man an der angehaengten Datei sieht, klappt das hier ueberhaupt nicht. Weil ihr mit der Animation auch Wellen am Strand bekommen wollt. Waren diese Wellen denn ueberhaupt noch zu sehen in einem Nightly vor r6964? (kanns gerade nicht testen)
Ich waere sehr erstaunt, wenn man die Krisselungen (wellenberge am oberen Kachelran) haette sehen koennen, da ja immer noch eine extra Strandkachel vorher kam.
Also "früher" konnte man es sehen, sonst hätte ich mir nicht die Mühe gemacht.

Geht auch noch mit Simutrans 112.3.

Edit: Nightly 112.4 r6947 geht es. Und Bild hinzugefügt.
Tschuldigung. Hab aber noch nicht verstanden woran es in den neuen Nightlies liegt. Also was muss ich verändern?
Wenn ich das richtig verfolgt habe: Die Kachel muss jetzt eine absolut flache Textur sein. Unsere bisherige Wassertextur ist "dreidimensional" und keine flache Kachel.
Schade um die Wellen. Sad

Die Wellen können aber nicht allein das Problem sein. Ich habe die entsprechende Datei angehängt. Einfach ins pak96.comic kopieren.

Da entstehen immer noch Fehler. Welche Datei ist das Problem?