Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Auswahlsignal routet auf besetztes Gleis
#1
Simutrans-Version:
111.2.3 Nightly r5729
PAK-Set (+zusätzliche PAK-Dateien):
pak128 + way.Overhead-Track.pak
Betriebssystem:
Win7

Fehler (möglichst genaue Beschreibung):
Beim Auswahlsignal reserviert der Zug ein Gleis, das schon besetzt ist und kann dann nicht einfahren. Da es ein Kopfbahnhof ist, kann der andere Zug auch nicht raus.
Interessanterweise nur bei Kühlwaren passiert, dort schon dreimal seit ich das nightly installiert habe.
[Bild: Fehler-Auswahlsignal.PNG]

Verhalten (Absturz, Einfrieren, ...):
Blockierte Züge
Zitieren
#2
Wenn reproduzierbar ist, bitte Spielstand hochladen ... Ansosnten sage ich mal, dass die dort schon seit 20 März dort hängen (denn erst da wurden die Reservierungen mitgespeichert).

Wenn nicht oder reproduzierbar => Spielstand
Zitieren
#3
Hier ist der Spielstand, die Züge klemmen auf 135,75,0

http://www.2shared.com/file/8GSy9HiF/128-g37.html

Dazu folgende Anmerkungen:
  • Ich hab den vorherigen Spielstand geladen, da fahren die Züge. Auch im Schnellvorlauf hat die Abfolge mehrmals korrekt funktioniert.
  • Der Stau ist an der Stelle schon einmal aufgetreten, da habe ich ihn aufgelöst und bis zum neuen Stau nichts an der Ecke geändert (auch nicht gespeichert / geladen)
  • Das gleiche Problem ist auch einmal bei 153,114,1 aufgetreten
  • Eben habe ich gesehen, das im Spielstand auch bei 181,308,0 zwei Züge ineinandergefahren sind. Ebenfalls im älteren Spielstand nicht der Fall.
Zitieren
#4
Also manche Konstruktionen (z.B. bei 385,450 haben ein Auswahlsignal auf einer Weiche. Das ist schonmal ein großen Nono (wie eigentlich jedes Signal auf einer Weiche meist nicht das macht, was man gemeinhin vermuten würde).
Zitieren
#5
Ich habe gerade genau das selbe Problem.


Simutrans-Version:
64pak 111.3 Nightly r5774
PAK-Set (+zusätzliche PAK-Dateien):
pakGer64 +(ein paar sachen aus PakJapan)
Betriebssystem:
Win7 32bit


Es ist reproduzierbar und ich habe das Pak und die Save mal gezippt und auf Dropbox hochgeladen.

https://www.dropbox.com/s/3c760npzwly3obo/Simubug.zip


Angehängte Dateien Bild(er)
   
Zitieren
#6
Seltsam, ich hatte dieses Problem ja wirklich sehr oft (aufgrund meiner Spielweise...) und dieses Problem schien bei mir behoben.

Hast du generell dieses Problem an mehreren Orten, oder jetzt nur dieser Zug an diesem Bahnhof zu dieser Zeit? Ich meine, dass dieses Problem (durch Benutzereinfluss) auch provoziert werden kann, so wie man auch Züge auf belegte Felder schicken kann.
Zitieren
#7
So eine Situation ist schon ein paar mal in anderen Spielständen aufgetreten aber es war nie reproduzierbar. Nachdem ich den jeweiligen Zug weg geschickt habe hatte sich die Sache immer erledigt.

Dieser Fall ist allerdings verfahren. Nach einer Erweiterung von zwei auf vier Gleise ist es zu einem unlösbaren Problem geworden.
Ich habe schon das Auswahlsignal neu gesetzt und auch schon an andere stellen gebaut aber es hilft einfach nichts.
Bisher habe ich es nur an diesem einen Bahnhof gemerkt aber auch nur weil es ein sehr frequentierter ist
Zitieren
#8
Hmm, ich würde das gerne ausführlicher testen, könntest du vielleicht noch das Autosave vom Juli dieses Spieljahres zur Verfügung stellen? So ist es ja nicht reproduzierbar, weil es schon passiert ist Tongue
Zitieren
#9
Ich habe noch 6 andere Spielstände kp ob sie nützlich sind.
*Edit*
https://www.dropbox.com/s/crzb4fmb95ozop4/save.zip
Zitieren
#10
Ich bin überzeugt, dass das mit einem anderen Phänomen zusammenhängt:
Teilweise werden bei einem Umbau die Blockstrecken nicht neu berechnet. Dann fährt der Zug an einem Signal vorbei und reserviert nur wenige Felder statt den ganzen Block bis zum nächsten Signal. Wenn das auf freier Strecke passiert, dann bremst der Zug auf 25km/h ab und fährt auf Sicht weiter, bis er an der Stelle durch ist.
Wenn das vor einem Kopfbahnhof passiert dann fährt er wohl auf Sicht, bis er direkt vor dem Zug steht, der schon im Bahnhof drin ist, und dann sind beide blockiert.

Lösungsvorschlag: Die Software scheint ja zu merken, dass etwas nicht stimmt, da der Zug nur langsam fährt. Könnte man dann nicht eine Neuberechnung der Blöcke rund um diesen Punkt auslösen?
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste