Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Absturz beim Fahrzeug zu Linie hinzufügen - Fatal Error: vector_tpl<T>
#1

  1. Version 120.2
  2. PAK-Set 192.comic
  3. Windows 10
  4. Hallo,
seit zwei Tagen probiere ich mich an dem Spiel. Leider hat sich nun ein hartnäckiger Bug eingestellt. Möchte ich einer bestimmten Linie einen Zug hinzufügen erscheint folgender Fehlertext und das Spiel stürzt ab:

FATAL ERROR: vector_tpl<T>::[] - 7koord3d: index out of bounds: 13 not in 0..12

Dies betrifft im Moment nur diese eine Linie. Ich habe das Spiel über Steam heruntergeladen. Wäre sehr Dankbar um Hilfe, genau die Mühle, die mehr Getreide braucht. Vielen Dank daher schonmal.

Nachtrag: Der Fehler scheint nicht Linienabhängig sondern Streckenabhängig zu sein, Erstelle ich eine neue Linie auf der selben Strecke stürzt das Spiel auch ab.
Zitieren
#2
Willkommen in Forum!!

Kanst Du bitte den Spielstand mal auf Simutrans.germany hochladen, und dann den Link hier posten?
Damit wird die Fehlersuche einfacher.
Zitieren
#3
ist das die NEUESTE Version?

Falls ja, glaube ich, das SIE (120.2) fehlerhaft ist. Ich habe ähnliche Probleme (Absturz des Spieles ohne angezeigte Fehlermeldung).

Spiel mal dein Spiel mit einer älteren/Nightly-Version.
Fatal ist, wenn sich das Licht am Ende des Tunnels als entgegenkommender ICE erweist.
Zitieren
#4
Da waere echt ein Savegame hilfreich + Anleitung, den Crash auszuloesen.
Zitieren
#5
vielleicht hilft hier r8129 weiter:

http://nightly.simutrans.com/en/

Bin mir aber nicht sicher, ob das derselbe Bug war/ist.
Zitieren
#6
Hallo,
ich habe den Fehler anscheinend auch, aber mit einer neueren Version:
Version: V120.2 r8077
PAK set: PAK128.german v0.9 r1966
OS: Mac OS 10.12.4

Der Bug erscheint, wenn ich im Depot einen Zug starten möchte.

Ich würde auch gern den Spielstand hochladen, aber leider weis ich nicht wo.
Der Link im Post von "the Transporter" funktioniert leider nicht.


Angehängte Dateien Bild(er)
   
Zitieren
#7
Herzlich Willkommen im Forum!

Danke für den Hinweis!
Der Link ist jetzt repariert und funktioniert wieder.

Mit dem Mac hast Du leider ein Problem, dafür gibt es keine Nightly Versionen.
Die einzige Alternative ist ein Downgrade auf die 120.1.3
Den Download gibt es auf SourgeForge
Zitieren
#8
Ok, der Link funktioniert wieder und ich scheine etwas hochgeladen zu haben:

http://simutrans-germany.com/files/uploa...3d_bug.sve


Ich hoffe es hilft den Bug zu finden.
Zitieren
#9
Version 120.2.2 kommt als bald, etwas Geduld bitte
Zitieren
#10
Sie ist da allerdings noch nicht (Stand: 31.03 14:30) für den Mac.
Wird aber auch bald zur Verfügung stehen.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste