Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
FPS Frame Rate immer unter 5 und oft auf 0 wie kann ich die Rate wieder erhöhen?
#1
Moin zusammen 

ich habe soeben mal in Einstellungen gesehen das die Frame Rate permanent im Keller ist. Ich nutze eine große map die allerdings noch nicht viel bebaut ist. Wie kann ich die Frame Rate wieder nach oben bekommen? Habe einen Lenovo Yoga500 Laptop.

Viele Grüße und vielen Dank 
140 002 Sunrail
Zitieren
#2
Hallo willkommen,

je mehr Kacheln simutrans gleichzeitig darstellen muss, um so mehr CPU Verbrauch. Fenster kleiner machen, oder rein zoomen.
Auf die Anzahl der Spieler Gebäude und Fahrzeuge kommt es gar nicht so an, sonder auf die Gesamtanzahl Elemente. Dazu zählen z.B. auch Bäume. Ausgedehnte Wälder können die CPU in Knie zwingen.

Denkbar sind auch Unverträglichkeiten zwischen Grafik-Treiber und den von Simutrans verwendeten Bibliotheken, da ich unter Linux spiele kann ich dazu nichts sagen.
Zitieren
#3
Der Arbeitsspeicher ist nicht ganz unbedeutend. siehe hier

Systemanforderungen

Gerade bei Laptops mit nur 4GB Ram und normaler HDD kann Speichermangel dazu führen das langwierig ausgelagert werden muss.

Und dann muss ich jetzt fragen, was bei Dir permanent im Keller heist?

Im Gegensatz zu Actionspielen und dgl ( min 30 fps, empfohlen 60 fps ) sind 25 fps bei Simutrans ausreichend ( glaube das war da sogar gedeckelt weil mehr nicht nötig ist, bin mir da aber nicht sicher ).
Simutrans Wiki | Online-Dat | SimuTranslator - RSS Feed

Unwissenheit schützt nicht vor Strafe
Zitieren
#4
Herzlich Willkommen im Forum!

Welche Ausstattung hat denn Dein Yoga 500?
Laufen noch andere Programme im Hintergrund?
Welches Grafikset, in welcher Version verwendest Du, sind auch Addons installiert? Die Version vom Grafikset wird beim laden vom Set angezeigt.
Welche Simutrans Version benutzt Du? Die Simutrans Versionsnummer steht oben links in der Kopfzeile.

Lade doch den Spielstand mal bitte auf dieser Seite hoch, und poste dann hier den Link.
Zitieren
#5
Über die Ausstattung kann ich leider nicht viel sagen da ich mich mit Laptops und PCs nicht so gut auskenne. Er hat 4GB Ram. Simutrans ist auf einer externen Festplatte installiert. Ich verwende Pak128.Japan mit vielen Addons Fahrzeugen , Gebäuden , Wege usw.
Zitieren
#6
Kurzes Googlen ergibt, dass beim Laden und unter längerer Last bei vielen Yoga 500 die CPU auf 0,46 GHz drosselt. Sollte das bei dir der Fall sein, hilft gar nichts. (Ok, manchen Leuten hat es geholfen, das Bios zu updaten und dann virtualisierung im Bios anzuschalten.) Allerdings gibt es verschiedene CPU Versionen mit dem Yoga 500, daher muss das nicht unbedingt der Fall sein.

Pak128.japan sollte aber flüssig laufen (wenn die CPU auf mehr als 1 GHz ist), wenn man nicht rauszoomt (also in originalgröße oder größer).

DenCPU-Takt findest du im Taskmanager in dem Leistungs-Tab.
Zitieren
#7
Das mit den 0,46 GHz klingt ja sehr nach thermischen Problemen. Das wird wohl eher die leistungsfähigeren CPU's betreffen, zumindestens in dieser Härte.

Falls Dich mehr Daten Deines Rechners interessieren, kann ich Dir CPU-Z empfehlen. Das Tool kann viele Informationen über die verbaute Hardware und deren Leistungsfähigkeit anzeigen.

Wie groß ist denn die Karte?
Wenn Du die Größe nicht im Kopf hast, einfach über die Minikarte auf die untere rechte Ecke gehen, denn Mauszeiger über das Eckfeld plazieren, dann wird die Pos. rechts unten in der Statuszeile angezeigt.

Lädst Du die Addons über einen Addon Ordner, oder sind die direkt im Grafiksetordner gespeichert?
Wenn die Addons sich in einem separaten Ordner befinden, kannst Du ja mal ohne Addons starten. Bei sehr vielen Addons kann das auch mal Probleme geben.
Zitieren
#8
Beim Yoga 500 scheint das ein Biosfehler zu sein, die CPU ist nähmlich in besagten Forenthreads nie wärmer als 50°C, und die Drusselung ist auch bei unter 30% im Akku fest vorgegeben ... Die Taktrate kann Windows anzeigen, für die Cpu is CpuZ in der Tat brauchbar.
Zitieren
#9
Das mit den 0,46 GHz klingt ja sehr nach thermischen Problemen. Das wird wohl eher die leistungsfähigeren CPU's betreffen, zumindestens in dieser Härte.

Das betrifft besonders Netbook-CPUs da die in der Regel ohne Lüfter auskommen müssen, bei den derzeitigen Temperaturen sind dann schnell 100 °C erreicht und die CPU geht auf Minimal-Takt. Laptops können bei hoher Raumtemperatur ebenfalls betroffen sein.

Hilfreich ist hier Core Temp. Das Programm listet die Temperatur und den Stromverbrauch der einzelnen Kerne auf. Zu der angezeigten Temperatur muss man allerdings noch 40 °C dazuzählen. Das ist kein Softwarefehler sondern liegt an Intel (Schnittstelle an der die Daten abgegriffen werden ist um den Betrag Kühler).
Zitieren
#10
Wir reden hier doch nicht über ein Netbook mit Atom Prozessörchen, sondern über einen Laptop, bei dem auch ein Core I7 Prozessor verbaut sein kann. Da ist immer ein Lüfter verbaut.
Und prissi hat doch schon geschrieben, das es ein BIOS Fehler ist.
Eine kurze Suche bei Lenovo bringt auch kein geeignetes Bios Update zutage.

Deshalb ist Hardwareseitig nicht wirklich eine schnelle Lösung zu finden. Hardware Informationen von CPU-Z wäre schon mal ganz interessant, um die Situation besser einschätzen zu können.
Evtl. läßt sich aber bei der Simutrans Installation noch was rausholen (Addons). Ansonsten hilft wohl nur eine kleinere Karte zu verwenden.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste