Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[120.4.1] Server start
#1
Ich weis nicht ob es ein lokales Problem ist oder ein generelles.

Wenn ich unter Linux mit -server bzw. -easyserver starte ( nur IPv4 ) wird der Server nicht beim Listserver gelistet.

Lade ich einen Spielstand als Serverspiel über das GUI, dann wird der Server gelistet.
Simutrans Wiki | Online-Dat | SimuTranslator - RSS Feed

Unwissenheit schützt nicht vor Strafe
Zitieren
#2
Wenn Server keinen gültigen Spielstand findet, dann ist das intern das gleiche wie das Laden eines neuen Spieles. Sprich, der Server wird immer beendet, wenn der Neue Welt Dialog erscheinen sollte. (Intern ist die Verarbeitung von Ereignissen ganz anders, ist dieser Dialog zu sehen.) Wenn man den Posixserver starte, erscheint auf der Commandozeile auch die Fehlermeldung, dass kein Spielstand geladen werden konnte und sich deshalb der Server beendet. Also so gewollt.
Zitieren
#3
Es wird genau das gleiche ausgegeben auf der Kommandozeile wie bei 120.3.

Ist ja auch genau die gleiche Konfiguration.

Einziger Unterschied, 120.3 wird gelistet und 120.4.1 wird nicht gelistet.

Der Spielstand wird gefunden und auch geladen. Das über die Oberfläche war ein Gegentest, ob es überhaupt funktioniert.

Und lokale Verbindung geht ja.
Simutrans Wiki | Online-Dat | SimuTranslator - RSS Feed

Unwissenheit schützt nicht vor Strafe
Zitieren
#4
Sorry, missverständnis.

Das war ein Fehler des Forums-Servers. Nach dem letzten apt-get upgrade hat der stillschweigend sein IP von statisch auf DHCP IP4 geändert. (Warum auch immer, sollte apt-get eingetlich in Ruhe lassen.) Daher wurde auch dem dualstack-Servern nur die IP4 gefunden. Bei Dualstack wurde aber IPv6 nach servers.simutrans.org angefragt, weswegen die IPs nicht übwereinstimmten und dann alles weitere fehlschlug. Das sollte allerdings gleichermaßen für den Start mit option oder Kästchen gelten ...

Wie auch immer, das Forum, dass die IP-Adresse aufläst, sollte jetzt weider eine alternative IPv6 zurückliefen und es sollte wieder alles gehen wie gehabt.
Zitieren
#5
Kann ich leider nicht bestätigen.

sim_posix wird nicht gelistet
simutrans ( also mit GUI ) wird gelistet

Allerdings sind das mit mixer_sdl2 erstellte Programmdateien.

Bin mir nicht sicher ob das am kompilieren ( makefile ) liegt. Wurde das nicht zwischen 120.3 und 120.4 verändert?
Simutrans Wiki | Online-Dat | SimuTranslator - RSS Feed

Unwissenheit schützt nicht vor Strafe
Zitieren
#6
Was vielleicht noch ein Grund sein kann, ich hab nur IPv4 gesetzt.

Und komischerweise wird nur die 'Secondary IP adress' gesetzt.
bei 'Server connection info' steht 0.0.0.0 drin.
Simutrans Wiki | Online-Dat | SimuTranslator - RSS Feed

Unwissenheit schützt nicht vor Strafe
Zitieren
#7
Andererseits fällt auf, das von den 3 jetzt noch gelisteten Servern nur meiner 120.4.1 verwendet ( per GUI als Netzwerkspiel geladen ).

Der pak128 hat 120.2.2 und der pak192.comic 120.3.
Simutrans Wiki | Online-Dat | SimuTranslator - RSS Feed

Unwissenheit schützt nicht vor Strafe
Zitieren
#8
Hmm, easyserver mit GUI geht, auch -server auf Kommandzeile und -server_dns gestzt geht. Aber in der Tat, der Posix-Server auf dem Forum geht nicht, (allerdings könnte da das ReverseDNS-lookup noch immer kaputt sein).
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste