Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Absturz Client aber nicht Server
#1
Leider noch Nighly R8973.
pak128.german_server

Absturz nur Client aber nicht Server.

Zitat:Core was generated by `/usr/lib/simutrans/sim -use_workdir'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  convoi_t::get_pos (this=0x0) at simconvoi.cc:570
570             if(anz_vehikel > 0 && fahr[0]) {
[Current thread is 1 (Thread 0x7f815e650740 (LWP 4845))]
(gdb) bt
#0  convoi_t::get_pos (this=0x0) at simconvoi.cc:570
#1  0x00000000004b3e62 in convoi_info_t::get_weltpos (this=0x239a9250, set=<optimized out>) at gui/../tpl/quickstone_tpl.h:249
#2  0x0000000000554976 in display_win (win=3) at gui/../display/../dataobj/../tpl/vector_tpl.h:232
#3  display_all_win () at gui/simwin.cc:1056
#4  0x0000000000557262 in win_display_flush (konto=1328457570.4100001) at gui/simwin.cc:1651
#5  0x00000000006782d6 in intr_refresh_display (dirty=dirty@entry=false) at player/finance.h:336
#6  0x00000000006bc164 in karte_t:Confusedync_step (this=this@entry=0x1f7a400, delta_t=<optimized out>, do_sync_step=do_sync_step@entry=true, display=display@entry=true) at simworld.cc:3586
#7  0x00000000006cdc81 in karte_t::interactive (this=this@entry=0x1f7a400, quit_month=quit_month@entry=2147483647) at simworld.cc:6800
#8  0x0000000000680ebe in simu_main (argc=argc@entry=2, argv=argv@entry=0x7ffdbfdf8e68) at simmain.cc:1455
#9  0x0000000000690d7c in sysmain (argc=2, argv=0x7ffdbfdf8e68) at simsys.cc:1061
#10 0x0000000000726984 in main (argc=<optimized out>, argv=<optimized out>) at simsys_s2.cc:788

Ich habe zu dem Zeitpunkt eigentlich nichts gemacht, nur den Schiffen beim fahren zugeschaut.
Hatte einige Fenster Linienplänen und Fahrzeuge offen.

Vielleicht kann jemand damit etwas anfangen.
Zitieren
#2
Ein Fahrzeug wurde zerstoert, aber das zugehoerige Fenster nicht rechtzeitig geschlossen. Das sollte eigentlich nicht moeglich sein :/
Zitieren
#3
(13-04-2020, Monday-15:00:30 )Dwachs2 schrieb: Ein Fahrzeug wurde zerstoert, aber das zugehoerige Fenster nicht rechtzeitig geschlossen. Das sollte eigentlich nicht moeglich sein :/

Im Netzwerk kann es an der Latenz liegen vermute ich mal blauäugig.

Ich spekuliere mal das Fenster nur auf dem Client erstellt werden. Fahrzeuge aber auf dem Server vermerkt sind.

Hat nun Client 1 ein Fahrzeugfenster auf und Client 2 entfernt das Fahrzeug was passiert dann?

- Client 2 entfernt das Fahrzeug und Fenster wird geschlossen
- Client 2 meldet das an den Server der das Fahrzeug ebenfalls entfernt
- der Server meldet allen anderen Clients das das Fahrzeug entfernt wurde
- Client 1 bekommt also die Info Fahrzeug weg aber schließt das Fahrzeugfenster vorher nicht

Ist jetzt reine Vermutung von mir das das so abläuft.

Wenn Client 2 dem Server nur meldet das er das Fahrzeug entfernen soll, dann gilt der letzte Punkt auch für Client 2.
Script-KI für Simutrans r9151+
Zitieren
#4
Sollte mir r9023 behoben sein. Das duerfte auch Andarix' Bug-Report betreffen.

Bug tauchte auf, wenn man ein Fenster von einem Fahrzeug, Bahnhof oder Fabrik oeffnete, dann ein neuer Client kam, dann das Fahrzeug, der Halt, die Fabrik geloescht wurde.
Zitieren
#5
Was ist eigentlich mit dem SVN ?
seit ein paar Tagen gibt svn://servers.simutrans.org/simutrans keine Antwort mehr.
Ich fliege da immer mit Timeout raus.
Früher ging es sehr langsam, dann ein paar Monate ratz fatz, und jetzt gar nicht mehr.
-----------------------
Schön wäre noch wenn das SVN auch via HTTP erreichbar wäre.
Dann müsste ich nicht immer auf meinem Server einlogen.
Das geht mit den Apache Modulen: dav_svn_module und dav_module

http://svnbook.red-bean.com/de/1.7/svn.s...httpd.html

Damit wäre das SVN Proxy fähig und würde nicht in irgendwelchen Filtern hängen bleiben.
Zitieren
#6
Auf dem SVN läuft aber kein Apache sondern nur SVN und node.js für die Serverliste. Letzteres beisst sich ohne Kunstgriffe mit Apache. Hat auch nur 512 MB Speicher und 5 GB Harddiskspeicher, aber für 9 Euro/Jahr will ich nicht meckern. Für den Timeout ist aber eher Isaacs DNS Server zuständig, denn von mir auch geht das SVN; es stellt halt keine Geschwindigkeitsrekorde auf, aber sollte innerhalb von 0.5s antworten..

Vielleicht ist es ein IP6 Problem. Bis vor ein paar Monaten gab es gar keine IP6 für servers.simutrans.org, (also keine AAAA record, der Server selber konnte IP6). Aber SVN kann es nicht gut. Normalerweise sollte man dann auf IPv4 zurückfallen, was aber Ubuntu nicht tut. Vielleicht "svn://5.135.125.166/simutrans" verwenden?

Wenn ich mit meinem 300ms+ Ping nach Europa keinen Timeout bekomme, solltest Du erst recht keinen haben.

Wieso musst du dich beim Server einloggen für SVN?
Zitieren
#7
Ich muss mich bei meinem Server, weil das der einzige Rechner ist der direkten Zugriff aufs Internet hat.
Alles andere steht hinter der Firewall und hat keinen direkten Zugriff sondern nur via Proxy.

Hm direkte Adresse ist ct234.pm2-host.1awww.com ?
werde ich gleich mal versuchen.
Zitieren
#8
Ok svn://5.135.125.166/simutrans geht.
Und auch recht schnell Smile
Zitieren
#9
»svn://ct234.pm2-host.1awww.com/simutrans« mag mich nicht -> Timeout
Könnte durchaus ein IP6 Problem sein.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste