Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Script-KI - Stationsbau
#31
Da war tatsaechlich ein Fehler drin, sollte in r9551 behoben sein. Da wurde zu zeitig abgebrochen ohne alle passenden Rotationen probiert zu haben. Sollte sehr selten auftreten. Den Bug habe ich vor 5 Jahren eingebaut Tongue
Zitieren
#32
(11-01-2021, Monday-21:39:33 )Dwachs2 schrieb: Da war tatsaechlich ein Fehler drin, sollte in r9551 behoben sein. Da wurde zu zeitig abgebrochen ohne alle passenden Rotationen probiert zu haben. Sollte sehr selten auftreten. Den Bug habe ich vor 5 Jahren eingebaut Tongue

Na ja, ich hatte öfters die Situation, das kein Dock gebaut wurde. Hab das Problem nur bisher zurück gestellt, weil es wichtigeres gab.

Aber seit Version 122.0 und den geänderten Klimaeinstellungen gibt es beträchtlich mehr Wasser auf den Karten. Dadurch kommt es nun öfters vor.

Und Feedback gibt es traditionell sehr wenig bei Simutrans. Die Aufbruchszeiten wo alles neu und interessant ist sind halt schon länger vorbei.
Script-KI für Simutrans r10401+ / Simutrans Nightly Builds
Zitieren
#33
(11-01-2021, Monday-21:39:33 )Dwachs2 schrieb: Da war tatsaechlich ein Fehler drin, sollte in r9551 behoben sein. Da wurde zu zeitig abgebrochen ohne alle passenden Rotationen probiert zu haben. ...

leider nicht komplett

1916_768x640.sve ~2 MByte (bis 07. Nov 2021)
leerer Spielstand

Auf Eckfelder wird kein Dock gebaut. Das geht auch von Hand nicht automatisch. Wobei da eine treffendere Fehlermeldung kommt.

Feld 439,406

[Bild: attachment.php?aid=17574]


Angehängte Dateien Thumbnail(s)
   
Script-KI für Simutrans r10401+ / Simutrans Nightly Builds
Zitieren
#34
Die Fehlermeldungen sollten eigentlich identisch sein.

build_harbour in ship-connector sollte eigentlich den Hafen schon mit der richtigen Ausrichtung bauen, so dass das mit den Eckfeldern kein Problem ist (fuer das Skript). Vielleicht wollten zwei KIs an die gleiche Stelle bauen?

Ich schau mir das Savegame heute abend mal an.
Zitieren
#35
Ich bilde mir ein, das das auch schon mal funktioniert hatte.
Script-KI für Simutrans r10401+ / Simutrans Nightly Builds
Zitieren
#36
Da war tatsaechlich eine gemeine Aenderung im Code, sollte wieder gehen r9560
Zitieren
#37
mal wieder etwas Werbung für die Script-KI, die sehr diszipliniert inzwischen zu Werke geht

Oder wie viele Stationen/Halteplätze lassen sich um eine Industrie bauen.

[Bild: attachment.php?aid=17597]

[Bild: attachment.php?aid=17598]


Angehängte Dateien Thumbnail(s)
       
Script-KI für Simutrans r10401+ / Simutrans Nightly Builds
Zitieren
#38
der Bahnsteig der Eisenbahn wurde die ganze Zeit nicht gebaut, jetzt geht es wieder

[Bild: attachment.php?aid=17721]


Angehängte Dateien Thumbnail(s)
   
Script-KI für Simutrans r10401+ / Simutrans Nightly Builds
Zitieren
#39
Belagerung von Brauerei und Papierfabrik

[Bild: attachment.php?aid=17723]

[Bild: attachment.php?aid=17724]


Angehängte Dateien Thumbnail(s)
       
Script-KI für Simutrans r10401+ / Simutrans Nightly Builds
Zitieren
#40
Ich glaube folgender Aufruf funktioniert nicht.

Code:
extension_list = building_desc_x.get_available_stations(building_desc_x.station_extension, wt_all, good_desc_x(freight))

und auch dieser nicht

Code:
extension_list = building_desc_x.get_available_stations(building_desc_x.station_extension, wt_all, good_desc_x("post"))

Was muss ich bei Waytype angeben für die Nebengebäude die keinem waytype haben?

wt_all scheint nämlich nicht zu funktionieren.
Script-KI für Simutrans r10401+ / Simutrans Nightly Builds
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste