Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Simutrans Nightlys mit openSUSE Leap 15.3
#1
Habe auf von openSUSE Leap 15.1 auf 15.3 aktualisiert. Habe dann Simutrans von https://download.opensuse.org/repositori...Leap_15.3/ installiert. Läuft auch soweit wie ich es nach einem kurzem Test beurteilen kann. (was schon immer nervt ist das die Version als Speicherort ".simutrans/save/" nutzt während die Nightlys "simutrans/save/" verwenden).

Wenn ich jetzt die Nightlys  verwenden möchte die ich schon mit 15.1 verwendet habe bekomme ich fehlende Bibliotheken gemeldet.
Erst fehlte die "libminiupnpc.so.17". Die habe ich hier gefunden und nachinstalliert.
Dann meldete die Konsole das "libsndio.so.7.0" fehlt. Die habe ich zwar hier gefunden, beim installieren bekomme ich aber die Meldung das "libc.so.6(GLIBC_2.33)(64bit)" fehlt, was mich wundert da glibc sowohl als 32 / 64bit Variante installiert sind und jeweils "libc.so.6" bereitstellen.

Habe jetzt irgendwie Angst mein neu aufgesetztes System gleich wieder zu verbasteln. Würde mich sehr über ein paar Tipps freuen denn ich würde schon gerne wieder die aktuellen Nightlys nutzen.
Aktuell installierte Simutransversion: nightly 10359

Simutrans = best thing since sliced bread

GEOTRANS ADDON
Zitieren
#2
Was mich jetzt wundert ist, das eine miniupnpc 1.7 nötig ist. Verwendet wird eigentlich eine 2er Version (aktuellste ist 2.2.2).
Ok das Package heist komplett libminiupnpc17-2.2.2-1.1.x86_64.rpm, ist also die Version 2.2.2.

Aus welcher Quelle verwendest Du die Nightlys?

Es gibt ja 3 Quellen. Wobei ich nicht weis ob 2 davon die gleichen Kompilate verwenden. Meine sind definitiv selbst erstellt.

https://nightly.simutrans.com/en/
https://github.com/Andarix/simutrans/releases
https://www.simutrans-forum.de/nightly/


Die Nightlys von mir sollten die wenigsten Probleme machen, da dort das meiste statisch gelinkt ist. Allerdings ist die Linuxversion noch nicht auf Fluidsynth umgestellt. Bei den Nightlys fehlt also Midi.
Script-KI für Simutrans r10401+ / Simutrans Nightly Builds
Zitieren
#3
(25-06-2021, Friday-17:56:28 )Andarix schrieb: Was mich jetzt wundert ist, das eine miniupnpc 1.7 nötig ist. Verwendet wird eigentlich eine 2er Version (aktuellste ist 2.2.2).
Ok das Package heist komplett libminiupnpc17-2.2.2-1.1.x86_64.rpm, ist also die Version 2.2.2.

Aus welcher Quelle verwendest Du die Nightlys?

Es gibt ja 3 Quellen. Wobei ich nicht weis ob 2 davon die gleichen Kompilate verwenden. Meine sind definitiv selbst erstellt.

https://nightly.simutrans.com/en/
https://github.com/Andarix/simutrans/releases
https://www.simutrans-forum.de/nightly/


Die Nightlys von mir sollten die wenigsten Probleme machen, da dort das meiste statisch gelinkt ist. Allerdings ist die Linuxversion noch nicht auf Fluidsynth umgestellt. Bei den Nightlys fehlt also Midi.
Ganz herzlichen Dank für die Hilfe!!!
Ich hatte die nightlys von https://nightly.simutrans.com/en/ verwendet. Mit dem nightly von https://www.simutrans-forum.de/nightly/
bekomme ich die gleiche Fehlermeldung scheint also identisch zu sein.
Mit dem Nightly von Dir https://github.com/Andarix/simutrans/rel...ightly.zip bekomme ich zwar keine Fehlermeldung und Simutrans startet auch ganz normal, nur leider wird die Schrift nicht richtig angezeigt.
   
Settings.xml löschen bzw. umbenennen hat auch nichts gebracht.
Aktuell installierte Simutransversion: nightly 10359

Simutrans = best thing since sliced bread

GEOTRANS ADDON
Zitieren
#4
(26-06-2021, Saturday-10:03:31 )Geotrans schrieb: ...
Mit dem Nightly von Dir https://github.com/Andarix/simutrans/rel...ightly.zip bekomme ich zwar keine Fehlermeldung und Simutrans startet auch ganz normal, nur leider wird die Schrift nicht richtig angezeigt.

Settings.xml löschen bzw. umbenennen hat auch nichts gebracht.

mmh, gibt noch die default.sve die wohl Einstellungen speichert.

Da wird die falsche Sprache oder der falsche Font geladen.

Weis nicht was angezeigt wird bei den Spracheinstellungen. Links der oberste Button in dem offenen Dialog ist die Spracheinstellung.

Die gewählte Sprache ist jedenfalls nicht Deutsch, weil die 2 Buttons die Schrift haben in Englisch sind. Das bedeutet das diese 2 keine Übersetzung in der gewählten Sprache haben.

Simutrans versucht seit r9872 die Sprache beim ersten Start zu erkennen. Möglich das das noch nicht richtig funktioniert. Wobei die Linuxversion noch nicht auf SDL2 2.0.14 umgestellt ist sondern noch 2.0.12 verwendet wo das nicht verwendet wird.

Zitat:Revision: 9872
Autor: prissi
Datum: Freitag, 11. Juni 2021 17:23:42
Meldung:
CHG: detect language on first start if possible
----

Wollte mich dieses Wochenende damit beschäftigen das umzustellen und auch Fluidsynth rein zu nehmen.
Script-KI für Simutrans r10401+ / Simutrans Nightly Builds
Zitieren
#5
(26-06-2021, Saturday-10:31:14 )Andarix schrieb: mmh, gibt noch die default.sve die wohl Einstellungen speichert.

Da wird die falsche Sprache oder der falsche Font geladen.

Weis nicht was angezeigt wird bei den Spracheinstellungen. Links der oberste Button in dem offenen Dialog ist die Spracheinstellung.

Die gewählte Sprache ist jedenfalls nicht Deutsch, weil die 2 Buttons die Schrift haben in Englisch sind. Das bedeutet das diese 2 keine Übersetzung in der gewählten Sprache haben.
Die default.sve zu löschen hat keinen Unterschied gemacht, aber nach Deiner Beschreibung habe ich die Spracheinstellung gefunden und deutsch eingestellt, jetzt sieht alles gut aus. Das Midi nicht funktioniert stört mich nicht, Ton am Rechner nervt mich eher, habe ich deshalb sowieso immer aus.

Nochmals vielen Dank für Deine Hilfe!!!
Aktuell installierte Simutransversion: nightly 10359

Simutrans = best thing since sliced bread

GEOTRANS ADDON
Zitieren
#6
(26-06-2021, Saturday-18:24:43 )Geotrans schrieb: ..., aber nach Deiner Beschreibung habe ich die Spracheinstellung gefunden und deutsch eingestellt, ...

Da lässt sich im Wiki nachsehen.

Sofern man die Hilfedatei kennt, kann man auch bei der Übersetzung der InGame-Hilfe nachsehen, da sind auch die Dialoge als Bilder abrufbar.

Übersetzung im Wiki
- Objektauswahl = help_file
- und in dem Fall die options.txt
- dann rechts bei der Anzeige links neben dem Titel oben auf das Icon [Bild: jpeg_file.png] klicken


SimuTranslator
Script-KI für Simutrans r10401+ / Simutrans Nightly Builds
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste